[重要なセキュリティのお知らせ] 偽の Qfinder Pro ウェブサイトが検出されました。もっと見る >

Why I'm not able to connect to the NAS via SSH since update to QTS 5.1.8 / QuTS h5.1.8 and QTS 5.2.0 / QuTS h5.2.0?


最終更新日: 2024-10-01

Applicable Products

  • QTS 5.1.8 and QTS 5.2.0
  • QuTS h5.1.8 and QuTS h5.2.0

Overview

QTS 5.1.8 / QuTS h5.1.8 and QTS 5.2.0 / QuTS h5.2.0 have updated OpenSSH to version 9.8p1, making some legacy algorithms obsolete. This update affects SSH connections, Rsync encryption, and SFTP.

Below are the supported host-key algorithms:

  • rsa-sha2-256
  • rsa-sha2-512

Recommendation

To avoid connection issues ("no hostkey alg" or "Corrupted MAC on input" error), we recommend the following:

  • Use the latest versions for third-party SSH clients such as PuTTY, MobaXterm, WinSCP, FileZilla, etc. If your client supports these algorithms but still fails to connect, adding the appropriate options with the specified algorithms, as shown above, should resolve the issue.
  • For Windows PowerShell, connect with the following command:
    ssh -m hmac-sha2-256 NAS_ADMIN@NAS_IP

この記事は役に立ちましたか?

50% の人が、これは役に立つと思っています。
ご意見をいただき、ありがとうございます。

さらにサポートが必要な場合は、コミュニティで他のユーザーや QNAP の専門家にご質問ください。 QNAP コミュニティへ

この記事の改善箇所をお知らせください。

その他のフィードバックがある場合は、以下に入力してください。

仕様を選択

      もっと見る 閉じる
      当ページを他の国/地域で見る:
      気軽にお問い合わせ! 気軽にお問い合わせ!
      back to top