How can I prevent HA pairing failure when using external storage devices?


Last modified date: 2025-07-25

Applicable Products

  • QuTS hero h5.3.0 and later
  • Storage Manager
  • High Availability Manager

Scenario

You want to create a high-availability (HA) cluster with external storage devices connected to the NAS devices. The external storage devices are identical between the two devices and are connected to the same ports or PCIe slots. However, when you try to create an HA cluster in High Availability Manager, the application fails to pair the NAS devices and indicates that they are inconsistent with each other.


Cause

Assuming the two NAS devices are consistent and compatible in all other aspects, HA pairing could fail if you connected the external storage devices to the NAS devices in different chronological orders. This would cause the corresponding external storage devices to have different enclosure IDs between the two NAS devices.

Enclosure IDs are typically assigned to external devices starting from "1", based on the chronological order in which they are connected to the NAS. If the corresponding external storage devices have different enclosure IDs between the two NAS devices, High Availability Manager will consider the two NAS devices to be inconsistent.


Solution

  1. Check if the enclosure IDs are inconsistent between the two NAS devices.
    On each NAS device, go to Storage Manager > Disks > Device to check the enclosure IDs of all external storage devices.
    Note
    If the enclosure IDs of the external storage devices are all consistent between the two NAS devices, the HA pairing likely failed due to some other inconsistency or incompatibility issue. Please check High Availability Manager for details to resolve the issue.
  2. Reinitialize the enclosure IDs on both NAS devices.
    1. For each pair of corresponding external storage devices between the two NAS devices, ensure the external storage devices are connected to the same port or PCIe slot.
    2. On each NAS device, go to Storage Manager > Disks > Device.
    3. Click > Recover > Reinitialize Enclosure IDs.
      This action resets all enclosure IDs and assigns each external storage device a new ID number starting from "1", based on the order of the ports and PCIe slots that the external storage devices are physically connected to.
  3. Ensure the enclosure IDs are consistent.
    On each NAS device, go to Storage Manager > Disks > Device to check the enclosure IDs of the external storage devices. Ensure they are consistent between the two NAS devices.

You can now try pairing the NAS devices in the cluster creation wizard in High Availability Manager.


Further Reading

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