What to do if the NAS HA status shows Locked
Applicable Products
All dual-controller NAS series
Symptom
In the NAS High Availability management page, it shows
High Availability Status: (Lock until MMDD hh:mm) or
High Availability Status: (Locked)
Root Cause
It usually happens when the connection of network or JBOD fails intermittently on one controller. When it happens, let's say it happens to the controller A (SCA), the other controller, controller B (SCB) takes over the system automatically to continue the services.
Once the connection resumes, it will perform the failback from SCA to SCB and the HA status resumes Active-Active.
But it comes with a state, Lock until MMDD-hh:mm and this state will remain for 24 hours.
Ex:
During this period, if the connection fails at the controller B again, the controller A will takeover the service again and the state becomes Locked. It means SCA locks the takeover state and it won't failback until human's intervention.
Solution
Since this may be a issue related to the hardware connection issue, we would recommend you checking your hardware connections (network and JBOD) first.
If you are sure the connection is fine but the HA state is Locked due to previous intermittent connection, please login your NAS command prompt with admin account via SSH.
Then run the command below to unlock HA state.
# cf unlock
After running this command, your NAS HAS status should resume Active-Active state.