Why do I encounter JBOD enclosure inconsistencies when pairing HA devices, even with identical configurations?


Last modified date: 2025-07-24

Applicable Products

  • QuTS hero h5.3.0 or later
  • High Availability Manager
  • Storage Manager

Scenario

During the initial paring of two NAS devices for high-availability (HA) cluster creation, the system checks whether the storage configurations of both NAS devices are identical, including connected JBOD enclosures. Even when the JBOD enclosure models, connected ports, installed disk slots, and disk capacities are consistent between the NAS devices, High Availability Manager may still report inconsistencies due to mismatched enclosure IDs, preventing HA cluster creation.


Root Cause

Enclosure IDs are usually assigned to expansion units in the chronological order that they are connected to the host NAS, starting from "1".

Even with identical JBOD enclosure models and configurations, connecting them to the two NAS devices in different chronological orders will result in mismatched enclosure IDs.


Solution

You can reinitialize enclosure IDs on both NAS devices. This assigns new enclosure IDs to the JBOD enclosures based on their physical connection order to each NAS device (that is, by port), instead of their chronological connection order.

  1. Ensure corresponding JBOD enclosures are connected to the same ports on both NAS devices.
    This ensures that all JBOD enclosures are connected in the same physical order on both NAS devices.
  2. For each NAS device, perform these actions:
    1. Log in as an administrator.
    2. Open Storage Manager.
    3. Go to Disks.
    4. Click ⋮ in the top-right corner of the Devices & Disks page, and then select Recover > Reinitialize Enclosure IDs.
      The system assigns new enclosure IDs to the JBOD enclosures based on their physical connection order.
  3. After enclosure IDs are reinitialized on both NAS devices, open High Availability Manager to restart HA cluster creation.

Further Reading

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