Why can't I mount the Dropbox cloud service in HBS 3 due to an authentication error?
Applicable Products
Hybrid Backup Sync
Symptom
When trying to mount Dropbox as a cloud service in HBS 3, the authentication process fails, even when using different browsers. The error message indicates a failed connection or authorization.
Root Cause
This issue is typically caused when the NAS cannot access Dropbox’s API endpoint at: https://api.dropboxapi.com
This may be due to firewall settings or network security devices blocking or filtering Dropbox-related traffic.
Solution
It means the NAS cannot access the Dropbox API endpoint: https://api.dropboxapi.com. Which is often caused by a firewall intercepting or categorizing Dropbox traffic. We can ssh login nas and use curl command to verify it.
How do I access my QNAP NAS using SSH?
curl –I https://api.dropboxapi.com --insecureBelow is an example for blocked.

Below is an example for allowed

Please add the following Dropbox domains to Allowlist( whitelist):
api.dropboxapi.com
content.dropboxapi.com
notify.dropboxapi.com
*.dropbox.com